Go Back   Sonos Forums > Getting Started with Sonos

Reply
 
Thread Tools Display Modes
  #1  
Old Jan 6th, 2012, 06:28 AM
chris pugh chris pugh is offline
Member
 
Join Date: Jan 2012
Posts: 6
Default Sonos cannot connect to Itunes library

Hi. New Sonos user here so sorry if my question is an ignorant one. When trying to add itunes libary via "add a share" it tells me that access is denied as I do not have Administrator rights. However, I do have administrator rights...

Any ideas?
Reply With Quote
  #2  
Old Jan 6th, 2012, 06:30 AM
the_lhc the_lhc is offline
Member
 
Join Date: Nov 2008
Posts: 2,186
Default

Have you actually shared your itunes directory?
Reply With Quote
  #3  
Old Jan 6th, 2012, 09:54 AM
turkish turkish is offline
Member
 
Join Date: May 2007
Posts: 3
Default

I'm having the same problem and I have shared the itunes library?
Reply With Quote
  #4  
Old Jan 6th, 2012, 09:55 AM
turkish turkish is offline
Member
 
Join Date: May 2007
Posts: 3
Default

I'm getting this error message:

Couldn’t share music in the folder ~/Music.

The computer “(null)” cannot be found.
Make sure that Windows Sharing is turned on, and that the computer is on your network. Please also check your firewall settings.
Reply With Quote
  #5  
Old Jan 6th, 2012, 11:14 AM
chris pugh chris pugh is offline
Member
 
Join Date: Jan 2012
Posts: 6
Default

Yes, checked that it's sharing. The full error is: Unable to create Sonos user: Admin rights needed (yes, I do have admin rights...)
Reply With Quote
  #6  
Old Jan 6th, 2012, 12:11 PM
NoBoB NoBoB is offline
Member
 
Join Date: Jan 2010
Location: USA
Posts: 2,761
Default

Assuming this is Windows, you might try right-clicking on the Sonos icon and selecting 'Run As Administrator' to ensure the program is running with admin rights.
Reply With Quote
  #7  
Old Jan 6th, 2012, 03:20 PM
Support - Sonos Support - Sonos is offline
 
Join Date: Aug 2008
Location: Santa Barbara, Ca
Posts: 469
Default

Hi there Chris,

Welcome to the club! Would you mind submitting a diagnostic so I can take a look? For instructions on how, please click here.

-C
__________________
Clay L
Sonos Customer Service
Reply With Quote
  #8  
Old Jan 7th, 2012, 03:16 AM
chris pugh chris pugh is offline
Member
 
Join Date: Jan 2012
Posts: 6
Default

Thanks. Have done.

Diagnostic ref: 2001786.
Reply With Quote
  #9  
Old Jan 11th, 2012, 12:48 AM
chris pugh chris pugh is offline
Member
 
Join Date: Jan 2012
Posts: 6
Default

Hi - any news on this please?

thanks
Reply With Quote
  #10  
Old Jan 11th, 2012, 10:55 AM
Support - Sonos Support - Sonos is offline
 
Join Date: Aug 2008
Location: Santa Barbara, Ca
Posts: 469
Default

Hi chris,

Sorry about that! That diag actually came through as corrupted, but what I could see from what was gathered was quite a bit of wireless noise.

I'd recommend trying a wireless channel change on your Sonos, try again and resubmit a diagnostic. For instructions on how to change channels, click here, please.

-C
__________________
Clay L
Sonos Customer Service
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 08:54 PM.