Go Back   Sonos Forums > Digital Music

Reply
 
Thread Tools Display Modes
  #1  
Old Jul 31st, 2011, 05:06 AM
cjtp cjtp is offline
Member
 
Join Date: Jul 2011
Posts: 6
Default Spotify search problems

Quote:
Originally Posted by sege View Post
I can't use Spotify since two weeks or so. I only get 'unable to browse music' or 'there was an error searching..'. Worthless, just mailed the support.

The downside with 'black boxes', I just don't know what to do? What's the problem? Where to look? Works perfect on my iPhone, my Macbook and so on but won't work on the Sonos boxes... :/
I've been experiencing the same. Had no changes done to my setup or network, and suddenly the Spotify account ceased to work in my Sonos P90. My spotify account does work on laptop and phone.

Internet radio on my Sonos does work, as well as my SAN MP3 storage access.

when I dump the network traffic I noticed that no network traffic leaves my sonos when I search the spotify service, no packet whatsoever. Again, using Internet radio traffic flows happily, so I am curious why the system does not even initiate traffic when doing a search. Firewall settings in my network allow all traffic to flow out (which even would not be my preferred set up).

I talked to support via telephone, but no luck yet. Not sure if they actually know what the problem might be.

Anyone have the solution to this problem?

Chris
Reply With Quote
  #2  
Old Jul 31st, 2011, 05:25 AM
ratty ratty is offline
Moderator
 
Join Date: Mar 2008
Location: Scotland
Posts: 14,464
Default

Welcome to the forums.

Did you try rebooting your ZP90, and/or removing and re-adding the Spotify service from your Sonos?
Reply With Quote
  #3  
Old Jul 31st, 2011, 05:43 AM
cjtp cjtp is offline
Member
 
Join Date: Jul 2011
Posts: 6
Default

Hi Ratty,

Yes, I did. This was something the guys at the support desk suggested too.

I also changed my password of Spotify to something with only letters and numbers, since I used a password before with additional characters like the pound key. Some systems seem not able to handle those.

Did not seem to make a difference.

Chris
Reply With Quote
  #4  
Old Jul 31st, 2011, 05:51 AM
ratty ratty is offline
Moderator
 
Join Date: Mar 2008
Location: Scotland
Posts: 14,464
Default

When you use the Desktop Controller and open the Music Services tab, is there a Spotify option? When you open it does it list Search/Starred/Playlists as expected?

If you've the ability to watch network activity on the Desktop Controller you should see traffic to an external address when you use Spotify search. (In my case it's to a 46.137.*.* address.)
Reply With Quote
  #5  
Old Jul 31st, 2011, 06:03 AM
cjtp cjtp is offline
Member
 
Join Date: Jul 2011
Posts: 6
Default

Hi,

When I open the services tab. I have the search option to search for either albums, artists or tracks. When I enter anything (for example Chopin), it returns after a couple of seconds with the "no results found" error.

I have a BSD system set up as a router. I can do a TCPdump on it, to watch traffic flowing through.
no IP traffic seems to leave the Sonos system when I use Spotify.

It does generate traffic when listening to Internet radio.

I have made some screenshots, but are not able to upload them here.
Reply With Quote
  #6  
Old Jul 31st, 2011, 06:12 AM
ratty ratty is offline
Moderator
 
Join Date: Mar 2008
Location: Scotland
Posts: 14,464
Default

Quote:
Originally Posted by cjtp View Post
When I open the services tab. I have the search option to search for either albums, artists or tracks.
That suggests the system knows about the account.

Quote:
When I enter anything (for example Chopin), it returns after a couple of seconds with the "no results found" error.

I have a BSD system set up as a router. I can do a TCPdump on it, to watch traffic flowing through.
no IP traffic seems to leave the Sonos system when I use Spotify.
Can you check for local DNS traffic and see if your Desktop Controller attempts to resolve any public addresses? The Spotify search conversation is between the controller and Spotify. It doesn't go via the ZonePlayer.
Reply With Quote
  #7  
Old Jul 31st, 2011, 06:38 AM
cjtp cjtp is offline
Member
 
Join Date: Jul 2011
Posts: 6
Default

Hi Ratty,

There does not seems to be any DNS query when I try to use the Spotify search option.

I then removed the spotify account from my Sonos system to see what happens on the wire when I add it again, since it appears to check the credentials.

When I add the account I DO see traffic from my sonos system going out to the internet. Both DNS query:

14:54:40.451527 192.168.5.117.1028 > 172.16.0.101.53: 5685+ A? system-api.sonos.com. (38)
14:54:40.493429 172.16.0.101.53 > 192.168.5.117.1028: 5685 1/4/0 A 72.46.236.70 (136)

and several packets on TCP port 443.

14:54:40.639363 72.46.236.70.443 > 192.168.5.117.1345: S 809127791:809127791(0) ack 3216054670 win 8190 <mss 1440> [tos 0x48]
14:54:40.639795 192.168.5.117.1345 > 72.46.236.70.443: . ack 1 win 5840 (DF)
14:54:40.641997 192.168.5.117.1345 > 72.46.236.70.443: P 1:59(58) ack 1 win 5840 (DF)
14:54:40.784884 72.46.236.70.443 > 192.168.5.117.1345: . ack 59 win 11052 [tos 0x48]
14:54:40.786690 72.46.236.70.443 > 192.168.5.117.1345: . 1:1381(1380) ack 59 win 64182 [tos 0x48]
14:54:40.786696 72.46.236.70.443 > 192.168.5.117.1345: P 1381:2043(662) ack 59 win 64182 [tos 0x48]
14:54:40.787407 192.168.5.117.1345 > 72.46.236.70.443: . ack 1381 win 8280 (DF)
14:54:40.787440 192.168.5.117.1345 > 72.46.236.70.443: . ack 2043 win 11040 (DF)
14:54:40.815487 192.168.5.117.1345 > 72.46.236.70.443: P 59:369(310) ack 2043 win 11040 (DF)
14:54:40.980082 72.46.236.70.443 > 192.168.5.117.1345: P 2043:2086(43) ack 369 win 63872 [tos 0x48]
14:54:40.983251 192.168.5.117.1345 > 72.46.236.70.443: P 369:1020(651) ack 2086 win 11040 (DF)
14:54:41.286070 72.46.236.70.443 > 192.168.5.117.1345: . ack 1020 win 63221 [tos 0x48]
14:54:41.344845 72.46.236.70.443 > 192.168.5.117.1345: P 2086:2499(413) ack 1020 win 63221 [tos 0x48]
14:54:41.345694 72.46.236.70.443 > 192.168.5.117.1345: P 2499:3042(543) ack 1020 win 63221 [tos 0x48]
14:54:41.384559 192.168.5.117.1345 > 72.46.236.70.443: . ack 3042 win 11040 (DF)
14:54:41.530993 72.46.236.70.443 > 192.168.5.117.1345: F 3042:3042(0) ack 1020 win 63221 [tos 0x48]
14:54:41.538127 192.168.5.117.1345 > 72.46.236.70.443: F 1020:1020(0) ack 3043 win 11040 (DF)
14:54:41.681178 72.46.236.70.443 > 192.168.5.117.1345: . ack 1021 win 63221 [tos 0x48]

After that however, again no Spotify :|

Chris
Reply With Quote
  #8  
Old Jul 31st, 2011, 07:04 AM
ratty ratty is offline
Moderator
 
Join Date: Mar 2008
Location: Scotland
Posts: 14,464
Default

[I split this discussion off the previous thread, which was more to do with Spotify dropout problems.]

The dialogue with system-api.sonos.com must relate to establishing the Spotify account. I see nothing there which relates to traffic with the Spotify server.

Close your Desktop Controller and start it afresh.

When you select Spotify off the Music Services tab you should see a DNS query for "ws-moapi.sonos.com".
Reply With Quote
  #9  
Old Dec 5th, 2011, 03:27 PM
cjtp cjtp is offline
Member
 
Join Date: Jul 2011
Posts: 6
Default Weird Sonos traffic when adding Spotify account

Hi,

Can anyone explain this network traffic when I add a spotify account in Sonos:

23:39:00.348624 192.168.5.60.1123 > 93.184.219.20.https: S 3165586560:3165586560(0) win 5840 <mss 1460,sackOK,timestamp 709388 0,nop,wscale 0> (DF)
23:39:00.362136 93.184.219.20.https > 192.168.5.60.1123: S 2583128234:2583128234(0) ack 3165586561 win 14600 <mss 1440,nop,nop,sackOK,nop,wscale 6> [tos 0x48]
23:39:00.362510 192.168.5.60.1123 > 93.184.219.20.https: . ack 1 win 5840 (DF)
23:39:00.363940 192.168.5.60.1123 > 93.184.219.20.https: P 1:59(58) ack 1 win 5840 (DF)
23:39:00.373817 93.184.219.20.https > 192.168.5.60.1123: . ack 59 win 229 [tos 0x48]
23:39:00.374477 93.184.219.20.https > 192.168.5.60.1123: . 1:1441(1440) ack 59 win 229 [tos 0x48]
23:39:00.374483 93.184.219.20.https > 192.168.5.60.1123: . 1441:2881(1440) ack 59 win 229 [tos 0x48]
23:39:00.374489 93.184.219.20.https > 192.168.5.60.1123: P 2881:4097(1216) ack 59 win 229 [tos 0x48]
23:39:00.374495 93.184.219.20.https > 192.168.5.60.1123: P 4097:4799(702) ack 59 win 229 [tos 0x48]
23:39:00.375202 192.168.5.60.1123 > 93.184.219.20.https: . ack 1441 win 8640 (DF)
23:39:00.375429 192.168.5.60.1123 > 93.184.219.20.https: . ack 2881 win 11520 (DF)
23:39:00.375486 192.168.5.60.1123 > 93.184.219.20.https: . ack 4097 win 14400 (DF)
23:39:00.375521 192.168.5.60.1123 > 93.184.219.20.https: . ack 4799 win 17280 (DF)
23:39:00.401841 192.168.5.60.1123 > 93.184.219.20.https: P 59:373(314) ack 4799 win 17280 (DF)
23:39:00.418700 93.184.219.20.https > 192.168.5.60.1123: P 4799:4846(47) ack 373 win 245 [tos 0x48]
23:39:00.421843 192.168.5.60.1123 > 93.184.219.20.https: P 373:1029(656) ack 4846 win 17280 (DF)
23:39:00.472223 93.184.219.20.https > 192.168.5.60.1123: . ack 1029 win 266 [tos 0x48]
23:39:00.574939 93.184.219.20.https > 192.168.5.60.1123: P 4846:5120(274) ack 1029 win 266 [tos 0x48]
23:39:00.574946 93.184.219.20.https > 192.168.5.60.1123: P 5120:5546(426) ack 1029 win 266 [tos 0x48]
23:39:00.574951 93.184.219.20.https > 192.168.5.60.1123: P 5546:5573(27) ack 1029 win 266 [tos 0x48]
23:39:00.574958 93.184.219.20.https > 192.168.5.60.1123: F 5573:5573(0) ack 1029 win 266 [tos 0x48]
23:39:00.578501 192.168.5.60.1123 > 93.184.219.20.https: P 1029:1056(27) ack 5574 win 17280 (DF)
23:39:00.581036 192.168.5.60.1123 > 93.184.219.20.https: F 1056:1056(0) ack 5574 win 17280 (DF)
23:39:00.590619 93.184.219.20.https > 192.168.5.60.1123: R 2583133808:2583133808(0) win 0 [tos 0x48]
23:39:00.590625 93.184.219.20.https > 192.168.5.60.1123: R 2583133808:2583133808(0) win 0 [tos 0x48]

(The 192.168.5.60 address is my internal network Sonos IP)

Weird, especially since 93.184.219.20 does not seem to resolve. Somehow it seems hardcoded in my sonos. No DNS query preceeds this network traffic.

Spotify not working by the way, but that issue is still not resolved

Chris
Reply With Quote
  #10  
Old Dec 6th, 2011, 01:21 AM
ratty ratty is offline
Moderator
 
Join Date: Mar 2008
Location: Scotland
Posts: 14,464
Default

93.184.219.20 doesn't appear to geolocate consistently. Some lookups put it in the EU, some in the US.

I got this:
Code:
==================================================
Order             : 1
IP Address        : 93.184.219.20
Host Name         : 
Resolved Name     : 
Country           : EU
Network Name      : EDGECAST-NETBLK-04
Owner Name        : NETBLK-04-EU -22
From IP           : 93.184.216.0
To IP             : 93.184.223.255
Allocated         : Yes
Contact Name      : Philip1 Goldsmith1
Address           : 2850 Ocean Park Blvd., Suite 110, Santa Monica CA 90405 USA
Email             : 
Abuse Email       : 
Phone             : +13104793200
Fax               : 
Whois Source      : RIPE NCC
==================================================
This thread started in July. Have you been back to Sonos Support?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 05:27 AM.