Go Back   Sonos Forums > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old Apr 18th, 2010, 03:20 AM
shiller shiller is offline
Member
 
Join Date: Nov 2006
Posts: 1
Default Using Sonos instead of PC speakers

One of my CP-100s is next to computer, which I use to watch movies.

Rather than purchase a second set of computer speakers I am attempting to route the computer sound via Sonos to the Sonos speakers.

I have set the line-in encoding to uncompressed under preferences and set the line-in level to 10.

Nevertheless, video and audio are still not synchronized. Using these settings has reduced the delay from 10 seconds to under 1 second.

Does anyone have advice as to how audio and video can be perfectly synchronized using this setup?

If this is not possible, does anyone have advice on which high quality computer speakers to purchase that can also be used as Sonos speakers while the computer is off? i.e. that have a separate audio line in?

Thanks in advance
Reply With Quote
  #2  
Old Apr 18th, 2010, 03:28 AM
Avee's Avatar
Avee Avee is offline
Moderator
 
Join Date: Oct 2005
Posts: 5,196
Default

Try using media player classic (not to be confused with windows media player). It allows to adjust audio delay in any direction while playing videos.
__________________
All opinions expressed here are my personal views.
I don't work for Sonos, I'm just another satisfied customer.
Reply With Quote
  #3  
Old Apr 19th, 2010, 09:40 AM
limegrass69 limegrass69 is offline
Member
 
Join Date: Jul 2008
Location: New York
Posts: 94
Default

Yeah...you're sort of in a tough spot. Anything that hits the Sonos will have some sort of delay introduced. Just the nature of the beast.

Avee's suggestion is good. You can introduce a video delay to compensate for the Sonos delay and get things synched up that way.
Reply With Quote
  #4  
Old Apr 23rd, 2010, 03:18 PM
parapoux parapoux is offline
Member
 
Join Date: Apr 2010
Posts: 2
Cool delay with the "line in" from the sonos

the reason why you get the delay is because you are using the "compress"sound... so youcould possibly send the sound in other room of your house....

so you be able to use the sonos locally as Computer speakers you need to open your sonos desktop controller
then on the top right click on "file" then "preferences" it will open anew window select the "advance tab" and on the second part of that page you can select "line in encoding" and set it as uncompressed.

That will do the trick.
have a great day
Reply With Quote
  #5  
Old Apr 24th, 2010, 02:00 AM
renowden's Avatar
renowden renowden is offline
Member
 
Join Date: Jul 2007
Location: Bristol, England
Posts: 252
Default

Err - he said right at the start "I have set the line-in encoding to uncompressed"!

I have never seen a 10 second delay, but you are right, you can't eliminate it entirely. Avee's solution looks the best.

Personally I use some reasonably decent powered speakers and switch the signal between ZP80 line out and the computer output using a very basic DJ crossfade mixer I had lying around. But, there again, I am not looking for super quality at this point.
__________________
Cheers,

Rick Parsons

Now 7 zones, 3 controllers + iPad, iPod, iPhone, Android Tablet, Windows & Mac controllers.
Hi-Fi is Cyrus/Quad/Rega/Linn connected to a zone in the record loop.
Computer is a Mac but with Windows running under VMware for some purposes - e.g. MediaMonkey which I prefer to iTunes.
Music is on a ReadyNAS Duo.
Reply With Quote
Reply

Tags
latency, line-in, sound delay, speakers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -8. The time now is 01:38 PM.